Thursday, June 28, 2012

Dell Force10 S4810 Virtual Link Trunking (VLT) Sample Configuration


Topology
=======================================

_________[MANAGEMENT_NETWORK]_______
|                                   |
|                                   |
172.28.17.252 MgmtPort                               MgmtPort 172.28.17.251
[Force10_VLTPeer1-S4810]Fo1/60---VLTI(ICL)---Fo0/60[Force10_VLTPeer2-S4810]
Te1/24                                Te0/24
|                                    |
|______________        ______________|
|       |
Gi1/45   Gi1/47
[Force10-S60]


Force10_VLTPeer1 Switch Configuration
=======================================
Force10(conf)#hostname Force10_VLTPeer1

1. Configure RSTP
Force10_VLTPeer1#configure
Force10_VLTPeer1(conf)#protocol spanning-tree rstp
Force10_VLTPeer1(conf-rstp)#no disable
Force10_VLTPeer1(conf-rstp)#00:04:08: %STKUNIT1-M:CP %SPANMGR-5-STP_ROOT_CHANGE: RSTP root changed. My Bridge ID: 32768:0001.e88b.1b1d Old Root: 32768:0000.0000.0000 New Root: 32768:0001.e88b.1b1d
Force10_VLTPeer1(conf-rstp)#bridge-priority 0
Force10_VLTPeer1(conf-rstp)#00:04:17: %STKUNIT1-M:CP %SPANMGR-5-STP_ROOT_CHANGE: RSTP root changed. My Bridge ID: 0:0001.e88b.1b1d Old Root: 32768:0001.e88b.1b1d New Root: 0:0001.e88b.1b1d
Force10_VLTPeer1(conf-rstp)#end

2. Check and open ports
Force10_VLTPeer1#show interfaces status | grep 24|60
Te 1/24               Down   Auto      Auto   --
Fo 1/60               Down   40000 Mbit Auto   --
Force10_VLTPeer1#configure
Force10_VLTPeer1(conf)#interface range te 1/24 , fo 1/60
Force10_VLTPeer1(conf-if-range-te-1/24,fo-1/60)#no shutdown
00:05:57: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Te 1/24
00:05:57: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Fo 1/60
Force10_VLTPeer1(conf-if-range-te-1/24,fo-1/60)#end

3a. Configure VLTI port-channel
Force10_VLTPeer1(conf)#interface port-channel 100
Force10_VLTPeer1(conf-if-po-100)#no switchport
Force10_VLTPeer1(conf-if-po-100)#no ip address
Force10_VLTPeer1(conf-if-po-100)#channel-member fortyGigE 1/60
Force10_VLTPeer1(conf-if-po-100)#no shutdown
00:07:00: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Po 100
Force10_VLTPeer1(conf-if-po-100)#end

3b. Configure VLT Domain
Force10_VLTPeer2#sh ip interface brief | grep YES
ManagementEthernet 0/0   172.28.17.251   YES Manual up                    up
Force10_VLTPeer1#configure
Force10_VLTPeer1(conf)#vlt domain 999
Force10_VLTPeer1(conf-vlt-domain)#back-up destination 172.28.17.251
Force10_VLTPeer1(conf-vlt-domain)#peer-link port-channel 100
Force10_VLTPeer1(conf-vlt-domain)#end

3c. Verify VLT Domain and VLTI (ICL) are working
(when Peer 2 configuration is completed)
Force10_VLTPeer1#show vlt brief
 VLT Domain Brief
------------------
 Domain ID:                    999
 Role:                         Secondary
 Role Priority:                32768
 ICL Link Status:              Up
 HeartBeat Status:             Up
 VLT Peer Status:              Up
 Local System MAC address:     00:01:e8:8b:1b:1d
 Remote System MAC address:    00:01:e8:8b:19:ac
Force10_VLTPeer1#


4. Configure access port-channel on peer
Force10_VLTPeer1#configure
Force10_VLTPeer1(conf)#interface tengigabitethernet 1/24
Force10_VLTPeer1(conf-if-te-1/24)#port-channel-protocol lacp
Force10_VLTPeer1(conf-if-te-1/24-lacp)#port-channel 110 mode active
00:22:42: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Po 110
Force10_VLTPeer1(conf-if-te-1/24-lacp)#exit
Force10_VLTPeer1(conf-if-te-1/24)#exit
Force10_VLTPeer1(conf)#interface port-channel 110
Force10_VLTPeer1(conf-if-po-110)#switchport
Force10_VLTPeer1(conf-if-po-110)#vlt-peer-lag port-channel 110
Force10_VLTPeer1(conf-if-po-110)#end

Force10_VLTPeer2 Switch Configuration
=======================================
Force10(conf)#hostname FOrce10_VLTPeer2

1. Configure RSTP
Force10_VLTPeer2#configure
Force10_VLTPeer2(conf)#protocol spanning-tree rstp
Force10_VLTPeer2(conf-rstp)#no disable
Force10_VLTPeer2(conf-rstp)#00:10:52: %STKUNIT0-M:CP %SPANMGR-5-STP_ROOT_CHANGE: RSTP root changed. My Bridge ID: 32768:0001.e88b.19ac Old Root: 32768:0000.0000.0000 New Root: 32768:0001.e88b.19ac
Force10_VLTPeer2(conf-rstp)#bridge-priority 4096
Force10_VLTPeer2(conf-rstp)#00:11:07: %STKUNIT0-M:CP %SPANMGR-5-STP_ROOT_CHANGE: RSTP root changed. My Bridge ID: 4096:0001.e88b.19ac Old Root: 32768:0001.e88b.19ac New Root: 4096:0001.e88b.19ac
Force10_VLTPeer2(conf-rstp)#end

2. Check and open ports
Force10_VLTPeer2#show interfaces status | grep 24|60
Te 0/24               Down   Auto      Auto   --
Fo 0/60               Down   40000 Mbit Auto   --
Force10_VLTPeer2#configure
Force10_VLTPeer2(conf)#int range te 0/24 , fo 0/60
Force10_VLTPeer2(conf-if-range-te-0/24,fo-0/60)#no shutdown
00:12:23: %STKUNIT0-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Te 0/24
00:12:23: %STKUNIT0-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Fo 0/60
Force10_VLTPeer2(conf-if-range-te-0/24,fo-0/60)#00:12:24: %STKUNIT0-M:CP %IFMGR-5-OSTATE_UP: Changed interface state to up: Fo 0/60
Force10_VLTPeer2(conf-if-range-te-0/24,fo-0/60)#end

3a. Configure VLTI port-channel
Force10_VLTPeer2#configure
Force10_VLTPeer2(conf)#interface port-channel 100
Force10_VLTPeer2(conf-if-po-100)#no switchport
Force10_VLTPeer2(conf-if-po-100)#no ip address
Force10_VLTPeer2(conf-if-po-100)#channel-member fortyGigE 0/60
Force10_VLTPeer2(conf-if-po-100)#00:13:50: %STKUNIT0-M:CP %IFMGR-5-OSTATE_DN: Changed interface state to down: Fo 0/60
Force10_VLTPeer2(conf-if-po-100)#no shutdown
00:13:55: %STKUNIT0-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Po 100
Force10_VLTPeer2(conf-if-po-100)#00:13:56: %STKUNIT0-M:CP %IFMGR-5-OSTATE_UP: Changed interface state to up: Fo 0/60
00:13:56: %STKUNIT0-M:CP %IFMGR-5-OSTATE_UP: Changed interface state to up: Po 100
Force10_VLTPeer2(conf-if-po-100)#end

3b. Configure VLT Domain
Force10_VLTPeer1#show ip interface brief | grep YES
fortyGigE 1/60           unassigned      YES Manual up                    up
ManagementEthernet 1/0   172.28.17.252   YES Manual up                    up
Port-channel 100         unassigned      YES Manual up                    up
Force10_VLTPeer2#configure
Force10_VLTPeer2(conf)#vlt domain 999
Force10_VLTPeer2(conf-vlt-domain)#back-up destination 172.28.17.252
Force10_VLTPeer2(conf-vlt-domain)#00:16:10: %STKUNIT0-M:CP %VLTMGR-6-VLT_HBEAT_UP: Heart beat link is up.
Force10_VLTPeer2(conf-vlt-domain)#peer-link port-channel 100
00:16:26: %STKUNIT0-M:CP %IFMGR-5-ACTIVE: Changed Vlan interface state to active: Vl 1
Force10_VLTPeer2(conf-vlt-domain)#00:16:26: %STKUNIT0-M:CP %VLTMGR-6-VLT_ELECTION_ROLE: Chassis is transitioning to primary role.
00:16:27: %STKUNIT0-M:CP %SPANMGR-5-STP_ROOT_CHANGE: RSTP root changed. My Bridge ID: 4096:0001.e88b.19ac Old Root: 4096:0001.e88b.19ac New Root: 0:0001.e88b.1b1d
00:16:27: %STKUNIT0-M:CP %VLTMGR-6-VLT_ICL_UP: InterChassis Link is up.
00:16:27: %STKUNIT0-M:CP %VLTMGR-6-VLT_PEER_STATUS: Peer chassis is up.
Force10_VLTPeer2(conf-vlt-domain)#end

3c. Verify VLT Domain and VLTI (ICL) are working
(Peer 1 configuration is completed)
Force10_VLTPeer2#show vlt brief
 VLT Domain Brief
------------------
 Domain ID:                    999
 Role:                         Primary
 Role Priority:                32768
 ICL Link Status:              Up
 HeartBeat Status:             Up
 VLT Peer Status:              Up
 Local System MAC address:     00:01:e8:8b:19:ac
 Remote System MAC address:    00:01:e8:8b:1b:1d

4. Configure access port-channel on peer
Force10_VLTPeer2#configure
Force10_VLTPeer2(conf)#interface tengigabitethernet 0/24
Force10_VLTPeer2(conf-if-te-0/24)#port-channel-protocol lacp
Force10_VLTPeer2(conf-if-te-0/24-lacp)#port-channel 110 mode active
00:34:36: %STKUNIT0-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Po 110
Force10_VLTPeer2(conf-if-te-0/24-lacp)#exit
Force10_VLTPeer2(conf-if-te-0/24)#exit
Force10_VLTPeer2(conf)#interface port-channel 110
Force10_VLTPeer2(conf-if-po-110)#switchport
Force10_VLTPeer2(conf-if-po-110)#vlt-peer-lag port-channel 110
Force10_VLTPeer2(conf-if-po-110)#end

Access Switch Configuration
=======================================
Force10#show interfaces status | grep 45|47
Gi 1/45               Down   Auto      Auto   --
Gi 1/47               Down   Auto      Auto   --
Force10#configure
Force10(conf)#interface range gi 1/45 , gi 1/47
Force10(conf-if-range-gi-1/45,gi-1/47)#no shutdown
02:02:46: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Gi 1/45
02:02:46: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Gi 1/47
Force10(conf-if-range-gi-1/45,gi-1/47)#02:02:46: %STKUNIT1-M:CP %IFMGR-5-OSTATE_UP: Changed interface state to up: Gi 1/45
02:02:46: %STKUNIT1-M:CP %IFMGR-5-OSTATE_UP: Changed interface state to up: Gi 1/47
Force10(conf-if-range-gi-1/45,gi-1/47)#port-channel-protocol lacp
Force10(conf-if-range-gi-1/45,gi-1/47-lacp)#port-channel 110 mode active
02:04:19: %STKUNIT1-M:CP %IFMGR-5-ASTATE_UP: Changed interface Admin state to up: Po 110
Force10(conf-if-range-gi-1/45,gi-1/47-lacp)#02:04:21: %STKUNIT1-M:CP %LACP-5-PORT-GROUPED: PortChannel-110-Grouped: Interface Gi 1/45 joined port-channel 110
02:04:21: %STKUNIT1-M:CP %IFMGR-5-OSTATE_UP: Changed interface state to up: Po 110
02:04:22: %STKUNIT1-M:CP %LACP-5-PORT-GROUPED: PortChannel-110-Grouped: Interface Gi 1/47 joined port-channel 110

Verifying Configuration
=======================================
1. Interfaces
Force10_VLTPeer1#show interfaces status | grep 24|60
Te 1/24               Up     1000 Mbit Full   --
Fo 1/60               Up     40000 Mbit Auto   --

Force10_VLTPeer1#show running-config interface te 1/24
!
interface TenGigabitEthernet 1/24
 no ip address
! 
 port-channel-protocol LACP
  port-channel 110 mode active
 no shutdown

Force10_VLTPeer1#show running-config interface fo 1/60
!
interface fortyGigE 1/60
 no ip address
 no shutdown

 Force10_VLTPeer1#show  interfaces port-channel brief
Codes: L - LACP Port-channel
    LAG  Mode  Status       Uptime      Ports         
    100  L2    up           00:40:32    Fo 1/60    (Up)
L   110  L2    up           00:05:13    Te 1/24    (Up)

Force10_VLTPeer1#show running-config interface po 100
!
interface Port-channel 100
 no ip address
 channel-member fortyGigE 1/60
 no shutdown
Force10_VLTPeer1#show running-config interface po 110
!
interface Port-channel 110
 no ip address
 switchport
 vlt-peer-lag port-channel 110
 no shutdown

2. RSTP
Force10_VLTPeer1#show running-config spanning-tree rstp
!
protocol spanning-tree rstp
 no disable
 bridge-priority 0

Force10_VLTPeer1#show spanning-tree rstp
Root Identifier has priority 0, Address 0001.e88b.1b1d
Root Bridge hello time 2, max age 20, forward delay 15, max hops 0
Bridge Identifier has priority 0, Address 0001.e88b.1b1d
Configured hello time 2, max age 20, forward delay 15, max hops 0
We are the root
Current root has priority 0, Address 0001.e88b.1b1d
Number of topology changes 2, last change occured 00:50:11 ago on Po 100

Port 101 (Port-channel 100) is designated Forwarding
Port is a Virtual Link Trunk Interconnect port
Port path cost 1400, Port priority 128, Port Identifier 128.101
Designated root has priority 0, address 0001.e88b.1b1d
Designated bridge has priority 0, address 0001.e88b.1b1d
 Designated port id is 128.101 ,designated path cost 0
Number of transitions to forwarding state 2
BPDU : sent 1550, received 7
The port is not in the Edge port mode

Port 111 (Port-channel 110) is designated Forwarding
Port is a Virtual Link Trunk port
Port path cost 18000, Port priority 128, Port Identifier 128.111
Designated root has priority 0, address 0001.e88b.1b1d
Designated bridge has priority 0, address 0001.e88b.1b1d
 Designated port id is 128.111 ,designated path cost 0
Number of transitions to forwarding state 0
BPDU : sent 458, received 0
The port is not in the Edge port mode

Force10_VLTPeer1#show spanning-tree rstp brief
Executing IEEE compatible Spanning Tree Protocol
Root ID    Priority 0, Address 0001.e88b.1b1d
Root Bridge hello time 2, max age 20, forward delay 15
Bridge ID    Priority 0, Address 0001.e88b.1b1d
We are the root
Configured hello time 2, max age 20, forward delay 15

Interface                                                Designated                 
 Name      PortID   Prio Cost    Sts         Cost        Bridge ID        PortID
---------- -------- ---- ------- ----------- ------- -------------------- --------
Po 100     128.101  128  1400    FWD(vltI) 0       0     0001.e88b.1b1d 128.101
Po 110     128.111  128  18000   FWD(vlt)  0       0     0001.e88b.1b1d 128.111

Interface
 Name      Role   PortID   Prio Cost    Sts         Cost    Link-type Edge
---------- ------ -------- ---- ------- ----------- ------- --------- ----
Po 100     Desg   128.101  128  1400    FWD         0       (vltI)P2P No 
Po 110     Desg   128.111  128  18000   FWD       0       (vlt) P2P No 

Force10_VLTPeer1#show spanning-tree rstp interface

Port-channel 100 is designated forwarding
Port is a Virtual Link Trunk Interconnect port

Edge port:no (default) port guard :none (default)
Link type: point-to-point (auto) bpdu filter:disable (default)
Bpdu guard :disable bpduguard shutdown-on-violation : disable RootGuard: disable LoopGuard disable
Bpdus sent 1519, received 7

Interface                                              Designated               
 Name     PortID   Prio Cost    Sts         Cost       Bridge ID         PortID 
--------- -------- ---- ------- ----------- ------- -------------------- --------
Po 100    128.101  128  1400    FWD(vltI) 0       0     0001.e88b.1b1d 128.101

Port-channel 110 is designated Forwarding
Port is a Virtual Link Trunk port

Edge port:no (default) port guard :none (default)
Link type: point-to-point (auto) bpdu filter:disable (default)
Bpdu guard :disable bpduguard shutdown-on-violation : disable RootGuard: disable LoopGuard disable
Bpdus sent 427, received 0

Interface                                              Designated               
 Name     PortID   Prio Cost    Sts         Cost       Bridge ID         PortID 
--------- -------- ---- ------- ----------- ------- -------------------- --------
Po 110    128.111  128  18000   FWD(vlt)  0       0     0001.e88b.1b1d 128.111

3. VLT
Force10_VLTPeer1#show running-config  vlt
!
vlt domain 999
 peer-link port-channel 100
 back-up destination 172.28.17.251

Force10_VLTPeer1#show vlt ?
backup-link             Backup-link information                
brief                   Brief information on the VLT           
detail                  Detail information on the VLT          
role                    Role of VLT peer                        
statistics              Statistics of the VLT     

Force10_VLTPeer1#show vlt backup-link
 VLT Backup Link
-----------------
 Destination:                    172.28.17.251
 Peer HeartBeat status:          Up
 HeartBeat Timer Interval:       1
 HeartBeat Timeout:              3
 UDP Port:                       34998
 HeartBeat Messages Sent:        2547
 HeartBeat Messages Received:    2116

 Force10_VLTPeer1#show vlt brief
 VLT Domain Brief
------------------
 Domain ID:                    999
 Role:                         Secondary
 Role Priority:                32768
 ICL Link Status:              Up
 HeartBeat Status:             Up
 VLT Peer Status:              Up
 Local System MAC address:     00:01:e8:8b:1b:1d

Force10_VLTPeer1#show  vlt detail
Local LAG Id  Peer LAG Id  Local Status  Active VLANs
------------  -----------  ------------  ------------
110           110          Up            1

Force10_VLTPeer1#show vlt role
 VLT Role
----------
 VLT Role:                     Secondary
 System MAC address:           00:01:e8:8b:19:ac
 Primary Role Priority:         32768
 Local System MAC address:     00:01:e8:8b:1b:1d
 Local System Role Priority:   32768

Force10_VLTPeer1#show vlt statistics
 VLT Statistics
----------------
 HeartBeat Messages Sent:       2679
 HeartBeat Messages Received:   2248
 ICL Hello's Sent:              2467
 ICL Hello's Received:          2233
 Domain Mismatch Errors:        0
 Version Mismatch Errors:       0
 Config Mismatch Errors:        0